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Introdução: 
A SolidWorks tem uma séria preocupação em ajudar você a agilizar o seu trabalho.  
A melhoria contínua no desempenho de grandes montagens e desenhos tem uma ênfase 
maior em cada lançamento do software. Com a adição de novas melhorias e o refinamento 
de funcionalidades existentes, o SolidWorks 2007 oferece agora um desempenho 
inigualável para grandes montagens e desenhos. 
 
Sobre o manual: 
Este manual é um guia de práticas recomendadas destinado aos usuários que desejam 
otimizar seu desempenho em grandes montagens e desenhos. Dedique algum tempo para 
ler sobre todas as técnicas. Nem todas as técnicas se aplicarão ao seu ambiente de projeto, 
portanto, identifique as técnicas que funcionem melhor para você. As técnicas indicadas a 
todos estão marcadas como TOTALMENTE RECOMENDADO. Para obter mais 
detalhes sobre as técnicas, consulte o Manual do Usuário do SolidWorks 2007 On-line 
ou clique em Ajuda para acessá-lo no SolidWorks. 
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O que é uma grande montagem? 
• Uma grande montagem é qualquer montagem complexa o suficiente para: 

o Maximizar os recursos do seu sistema 
o Prejudicar a produtividade 

Quais são os sinais que indicam problemas com uma grande montagem?  
• Uma grande montagem causará uma degradação do desempenho nas seguintes áreas: 

o Abrir e salvar 
o Reconstruir 
o Criação de desenho 
o Rotação e visualização 
o Posicionamento 

Que fatores afetam o desempenho de uma grande montagem? 
• Configurações gerais (Opções) 
• Montagens (Peso leve ou resolvida, posicionamento, configurações, referências 

externas) 
• Desenhos (Peso leve ou resolvida, configurações, vistas, qualidade da exibição) 
• Peças (Esboços, referências externas em detalhe) 
• Gerenciamento de dados (Gerenciamento de dados manual, PDMWorks) 
• Hardware (CPU, memória, placa de vídeo, SO) 
• Ambiente (Rede, metodologia de recuperação) 
• Próximas etapas 
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Configurações gerais: 
 
Modo de Grande montagem e Montagens em Peso Leve: TOTALMENTE 
RECOMENDADO 

• Peso leve é uma combinação de configurações de Opções que resultam no 
desempenho melhorado 

• Inclui uma configuração de opção para acionar montagens Peso leve (consulte 
“Montagens” abaixo) 

• Um limite baseado em número de peças na montagem pode ser definido para 
acionar o Modo de Grande montagem 

• Podem ser ativados instantaneamente – Ferramentas (Tools) > Grande montagem 
(Large Assembly) 

 

 
Para ativar o Modo de Grande montagem: Ferramentas (Tools) > Modo de Grande 

montagem > (Large Assembly Mode) 
 

• Quando ativado, o Modo de Grande montagem torna algumas configurações de 
Opções não editáveis (as opções aparecem obscurecidas); quando desativado, 
as opções voltam ao normal (editáveis). 
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Algumas opções de Exibição/seleção (Display/Selection) estão obscurecidas 

(não editáveis) no Modo de Grande montagem 
 

Opções do Modo de Grande montagem: 
• É possível alterar as configurações do Modo de Grande montagem: Ferramentas 

(Tools) > Opções (Options) > Montagens (Assemblies) 
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• As opções totalmente recomendadas são: 

 
Opções do Modo de Grande montagem 

 
• Carregar componentes de peso leve automaticamente 
• Não salvar informações de recuperação automática 
• Ocultar todos os eixos planos, esboços, curvas, anotações, etc. 
• Não exibir arestas no modo sombreado 

 
Para aprimorar o desempenho, não exiba arestas no modo sombreado 

 
Desempenho 

• As configurações relacionadas ao desempenho podem ser encontradas em 
Ferramentas (Tools) > Opções (Options) > Desempenho (Performance) 

• “Sem visualização ao abrir” (No preview during open) permite a abertura mais 
rápida do modelo, porém não fornece uma visualização – não é controlado pelo 
Modo de Grande montagem 
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M
 

ontagens: 

Como funcionam as montagens 
• As montagens são resolvidas sucessivamente nesta ordem: 

 

  
Dicas sobre “Posicionamentos” (Mates) 

• Posicionar vários componentes em relação a uma referência comum é melhor que 
“colocar em cadeia” 

o Exemplo: posicione 3 parafusos em uma chapa plana. Posicione a parte 
inferior da cabeça na superfície superior da placa em vez de posicionar a 
parte superior do parafuso B na parte superior do parafuso A, a parte 
superior do parafuso C na parte superior do parafuso B e assim por diante 

• Desempenho do posicionamento em ordem de velocidade (mais rápido a mais lento): 
o Posicionamentos de relação (Coincidente, Paralelo, etc.) 
o Posicionamentos lógicos (Largura, Came, Engrenagem) 
o Posicionamentos de distância 
o Posicionamentos de limite 

Evite referências circulares 
• Ocorre com mais freqüência no posicionamento de recursos em contexto 
• Também pode ocorrer no posicionamento de padrões de componentes 
• Um sintoma comum de referências circulares são montagens que requerem mais de 

uma reconstrução 
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Montagens em peso Leve: TOTALMENTE RECOMENDADO 
• Pode-se carregar uma montagem com seus componentes ativos totalmente 

resolvidos ou peso leve. Tanto peças como submontagens podem ter peso leve. 
• Quando um componente é totalmente resolvido, todos os dados do modelo são 

carregados na memória. 
• Quando um componente é peso leve, somente um subconjunto de dados do modelo 

é carregado na memória. Os dados restantes do modelo são carregados de acordo 
com a necessidade. 

• O Modo de Grande montagem (consulte “Configurações gerais” acima) pode ser 
configurado para que as montagens sejam automaticamente abertas como peso leve 
se houver mais de um determinado número de componentes. 

 

 
Os componentes peso leve são exibidos 

com um ícone de uma pena no FeatureManager 
 

• Você pode melhorar significativamente o desempenho de grandes montagens 
usando componentes peso leve. Carregar uma montagem com componentes peso 
leve é mais rápido que carregar a mesma montagem com componentes totalmente 
resolvidos. Montagens com componentes de peso leve são reconstruídas mais 
rapidamente porque menos dados são avaliados. 

• Componentes de peso leve são eficientes porque os dados do modelo completo dos 
componentes são carregados somente conforme a necessidade. Somente 
componentes afetados pelas alterações feitas na sessão de edição atual se tornam 
totalmente resolvidos. Você pode executar as seguintes operações de montagem em 
componentes de peso leve sem resolvê-los: 

 
Adicionar/remover posicionamentos Detecção de interferência 
Seleção de aresta/face/componente Detecção de colisão 
Recursos da montagem Anotações 
Medida Dimensões 
Propriedades da seção Geometria de referência da 

montagem 
Propriedades de massa Vistas da seção 
Vistas explodidas Seleção avançada de componentes 
Simulação física Exibir/ocultar avançado de 

componentes 
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• Quando um componente é peso leve, uma pena aparece no ícone deste componente 
na árvore de projeto do FeatureManager. 

• Para ativar o carregamento peso leve automático de componentes: 
o Clique em Ferramentas (Tools) > Opções (Options) > Desempenho 

(Performance) 
o Em Montagens (Assemblies), selecione Carregar componentes peso-leve 

automaticamente (Automatically load components lightweight). 
o Se a opção anterior não for selecionada, você poderá abrir manualmente uma 

montagem com seus componentes peso-leve. 
• Para abrir manualmente uma montagem com componentes peso-leve: 

o Clique em Arquivo (File), Abrir (Open). 
o A caixa de diálogo Abrir é aberta. 
o Selecione Peso leve (Lightweight), procure o arquivo de montagem e clique 

em Abrir. 
o Todos os componentes da montagem são carregados como peso leve. 

• Para definir um ou mais componentes resolvidos como peso leve: 
o Para um único componente, clique com o botão direito no componente e 

selecione Definir como peso leve. 
o Para uma montagem inteira, clique com o botão direito no ícone de 

montagem de nível superior e selecione Definir resolvida como Peso leve 
(Set Resolved to Lightweight). 

o Para uma submontagem e seus componentes, clique com o botão direito no 
ícone de submontagem e selecione Definir resolvida como peso leve. 
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Abrir grandes montagens de peso leve: TOTALMENTE RECOMENDADO 
 

 
Você pode abrir uma montagem no modo Peso leve 

 
 

• Para abrir manualmente uma montagem com componentes peso-leve: 
o Clique em Arquivo (File), Abrir (Open). 
o A caixa de diálogo Abrir é aberta. 
o Selecione Peso leve (Lightweight), procure o arquivo de montagem e clique 

em Abrir. 
o Todos os componentes da montagem são carregados como peso leve. 

• Para definir um ou mais componentes resolvidos como peso leve: 
o Para um único componente, clique com o botão direito no componente e 

selecione Definir como peso leve. 
o Para uma montagem inteira, clique com o botão direito no ícone de 

montagem de nível superior e selecione Definir resolvida como Peso leve 
(Set Resolved to Lightweight). 

o Para uma submontagem e seus componentes, clique com o botão direito no 
ícone de submontagem e selecione Definir resolvida como peso leve. 
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Para abrir somente a árvore de projeto do FeatureManager 
• A seqüência “Arquivo – Abrir – Avançado” (File – Open – Advanced) permite abrir 

uma montagem, somente a árvore de projeto, quase que instantaneamente 
• Em seguida, resolva o que for necessário 
• Quando você resolve submontagens na versão 2007, elas se tornam peso-leve 
 

 
Para abrir somente a árvore de projeto 

 
Usar submontagens: TOTALMENTE RECOMENDADO 

• Use submontagens – evite estruturas planas com muitos posicionamentos 
o Em submontagens, somente submontagens que precisam de atualização 

serão atualizadas. 
o Se a montagem for plana e sem submontagens, todos os posicionamentos de 

todas as peças serão atualizados. 
• Se desejar exibir a movimentação de uma submontagem, poderá transformá-la em 

uma submontagem flexível. 
 
Usar Configurações de montagens onde for apropriado 

• As configurações de montagens permitem suprimir peças e substituir configurações 
“simplificadas” de peças por modelos acabados mais complexos 

• Ao suprimir peças e recursos, mais RAM é liberada 
• Nota: Use configurações se preferir manter as configurações simplificadas neste 

nível da montagem ou se for por questões de projeto (uma nova configuração de 
projeto). Não use configurações para simplesmente Ocultar/exibir peças, pois as 
configurações são SEMPRE reconstruídas. Consulte “Estados de exibição” abaixo 
se desejar apenas ocultar e exibir muitas peças com uma seleção. 

• Ao simplificar peças, verifique se não está suprimindo superfícies que são 
necessárias nos posicionamentos 

 

SolidWorks – Confidencial 



 
 

• Configurações de nível de montagem conferem ao SolidWorks a flexibilidade para 
controlar: 

o Configurações de nível de peça 
o Supressão de peças 
o Visibilidade da peça 
o Estado de supressão de posicionamentos 
o Modificação de recursos da montagem 
o Supressão de padrões de componente 
o Propriedades específicas da configuração 
o Valores de posicionamentos de distância e ângulo 

• Sempre abra a montagem com a configuração correta ativa para economizar tempo; 
assim não será necessário alternar para a configuração desejada 

 
Usar Estados de exibição onde for apropriado 

• Estados de exibição NUNCA requerem uma reconstrução, Configurações são 
SEMPRE reconstruídas 

• Nota: Para Ocultar/exibir e visualização avançada, use Estados de exibição; para 
exibir versões diferentes de um projeto, use Configurações 

• Controles: 
o Visibilidade da peça 
o Modo de exibição 
o Textura 
o Transparência 
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Para adicionar um Estado de exibição 

 
Usar Isolar 

• Use Isolar para ocultar rapidamente todos, menos os componentes selecionados 
• Configuração temporária que permite selecionar e manipular o modelo com mais 

facilidade 
 

 
Isolar pode ser usado para ocultar rapidamente 

todas as peças, exceto aquelas selecionadas 
 
Reparar referências em falta/quebradas 

• Garante a precisão e as velocidades com que a montagem é reconstruída 
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Rota elétrica  
• Rota de conector a conector, não de pino a pino 
• Exibe as informações pino-a-pino em uma tabela no desenho de fiação 

 
Técnicas de modelagem avançadas: USE ONDE FOR APROPRIADO 
As técnicas de modelagem listadas abaixo são avançadas, mas possuem vantagens e 
desvantagens. Lembre-se de usar essas técnicas com cuidado e use somente aquelas que 
julgar apropriadas à sua situação: 
 

Técnica de “Layout” ou “Estrutura” 
• Essa técnica serve para o projeto conceitual ou layout inicial de uma grande 

montagem. Ela é mais eficaz no projeto de uma grande montagem com muitas 
relações complexas entre sistemas (como uma correia transportadora em execução 
entre submontagens de uma máquina empacotadora, uma copiadora, uma 
ferramenta de máquina, etc). 

• Crie uma peça que representará o layout geral simplificado da montagem – também 
conhecido como peça de estrutura 

• Na maioria das vezes é um esboço 2D, parecido com um corte transversal do projeto 
• Pode conter esboços, planos, pontos, superfícies, o que for necessário para definir a 

estrutura do nível de detalhes desejado 
• É possível usar a funcionalidade de Blocos de esboço (Sketch-Blocks) para criar 

mais facilmente a estrutura e até mesmo criar mecanismos que realizem o 
movimento cinético da montagem 

• Essa peça de estrutura poderá ser adicionada como primeira peça da montagem 
• As submontagens também podem usar esse recurso como o primeiro componente, 

de forma que, mesmo que você abra apenas uma submontagem, ainda possa ver e 
selecionar referências da peça de estrutura que representa as referências críticas 
gerais da montagem inteira 

• As peças podem ser montadas na peça de estrutura na submontagem ou na estrutura 
de uma montagem de nível superior 

• As peças de estrutura podem ser filtradas na BOM (lista de materiais) para que não 
apareçam 

• Atenção: Se você criar referências no contexto para a estrutura, ou peças montadas 
de um mecanismo para a estrutura, não será possível arrastar livremente os 
componentes. A posição do componente será atualizada se a estrutura for alterada. 

 
Técnica de múltiplos corpos 
• Se houver peças em uma montagem com relações entre peças extremamente 

complexas (ou seja, corpo de um violão de madeira laminada, cavidade de molde, 
etc.), talvez seja necessário usar múltiplos corpos 

• É possível “dividir” as peças como uma montagem; a localização das peças na 
montagem dividida é automaticamente controlada pela peça com múltiplos corpos 

• Os recursos adicionados às peças “divididas” (furos do assistente de perfuração, 
casca etc.) não são devolvidos à peça com múltiplos corpos 
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• Atenção: Peças individuais são completamente dependentes do modelo de 
múltiplos corpos. Algumas alterações nas peças podem ocorrer na peça com 
múltiplos corpos. 

 
Técnica de Inserir peça 
• Se você tem um projeto com apenas poucas relações complexas entre as peças, 

poderá optar por modelar somente a geometria compartilhada ou referências (ou 
seja, o revestimento externo da almofada de porta de um carro, o esboço de uma 
placa de circuito impresso, a capa do telefone celular, etc) 

• Modele superfícies, planos de referência ou outras geometrias de referência que 
serão utilizadas por peças de múltiplos corpos 

• Inicie novas peças e insira essa peça em cada modelo como o primeiro recurso 
• Se a peça inserida no projeto for atualizada, todas as peças serão atualizadas 
• Atenção: Semelhante aos cuidados com múltiplos corpos. Ainda há uma referência 

externa à peça inserida. Alterações nesses recursos precisam ocorrer na peça inserida. 
 

Como trabalhar com grandes configurações 
• Carregue configurações “pesadas” enquanto trabalha em configurações “mais leves” 
• Faça isso tornando inativas configurações pesadas, mas defina Propriedades para 

aceitar novos componentes, seus posicionamentos etc. 
 

 

Configuração 
inativa 

Configuração 
ativa 

Deixar desmarcado 

Torne inativas as configurações pesadas, trabalhe em configurações mais leves 
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Série de furos 
• Use Série de furos (Hole Series) para criar furos em várias peças e adicionar 

automaticamente pilhas de componentes de fixação (ou seja, parafusos, arruelas, 
porcas, etc.) 

• Inserir (Insert) > Recurso de montagem (Assembly Feature) > Furo (Hole) > 
Série de furos (Hole Series) 

• Garante que os furos serão alinhados e os componentes de fixação corretos serão 
adicionados aos furos 

• Exibição do furo no nível da peça 
• Seleção do componente de fixação baseado no Assistente de Perfuração 
• A BOM será precisa com componentes de fixação corretos 
• Atenção: Cria referência externa porque um ponto de esboço de furo é criado 

 
Bloquear referências externas 
• O bloqueio de referências externas evita uma reconstrução causada por uma 

referência externa 
• Recomendamos decidir se deseja referências externas antecipadamente 

 
 

 
Você pode decidir antecipadamente se deseja criar referências externas ou não 

 usando a opção “Não criar referências externas para o modelo” 
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Referências externas podem ser visualizadas, quebradas e bloqueadas 

 
Suspender reconstruções automáticas 

 

 
Suspensão de reconstruções automáticas 

 
• É possível adiar a atualização de montagens até você estar pronto para reconstruí-la. 

Adiando a atualização, você pode fazer várias alterações, depois reconstruir a 
montagem de uma vez. A montagem ainda é reconstruída automaticamente, 
se necessário, para atualizações internas e para proteger a integridade do modelo  
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• Atenção: Use esta opção somente quando absolutamente necessário. Erros de 
reconstrução criados enquanto esta opção estiver ativa não serão aparentes até que 
a opção seja desativada (ou que você faça uma reconstrução manual), o que pode 
dificultar a determinação da causa dos erros 

• Para adiar a atualização das montagens:  
o Clique com o botão direito no nome da montagem, no topo da árvore de 

projeto do FeatureManager, e selecione Suspender reconstrução automática 
(Suspend Automatic Rebuild) 

o (Reconstrução suspensa) aparece na barra de status  
• Para atualizar manualmente quando estiver no modo Suspender reconstrução 

automática: 
o Clique em Reconstruir na barra de ferramentas Padrão 

• Para desativar a opção: 
o Clique com o botão direito no nome da montagem, no topo da árvore 

de projeto do FeatureManager, e desmarque Suspender reconstrução 
automática 

• Você precisa redefinir a opção sempre que carregar o documento da montagem 
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Desenhos: 
 
Desenhos peso-leve: TOTALMENTE RECOMENDADO 

• Desenhos peso-leve são semelhantes a montagens peso-leve. Quando um desenho é 
peso leve, somente um subconjunto de dados do modelo é carregado na memória. 
Os dados restantes do modelo são carregados conforme necessário.  

• O desempenho de desenhos de grandes montagens é melhorado significativamente 
com desenhos peso-leve. Carregar um desenho peso-leve é mais rápido que carregar 
o mesmo desenho com peças totalmente resolvidas. 

• Desenhos de peso leve são eficientes porque os dados do modelo completo são 
carregados somente conforme a necessidade. 

• Para carregar um desenho como peso leve: 
o Ao abrir um desenho, selecione Peso Leve na caixa de diálogo Abrir.  

• Para definir componentes da montagem como peso leve ou resolvido: 
o Clique com o botão direito em um componente e selecione Definir como 

Peso leve ou Definir como resolvido. 
o Quando um componente é peso leve, uma pena aparece no ícone da peça na 

árvore de projeto do FeatureManager. 
• Para definir vistas de desenho como peso leve ou resolvido: 

o Clique com o botão direito em uma vista de desenho e selecione Definir 
resolvida como Peso Leve (Set Resolved to Lightweight) ou Definir Peso 
Leve como resolvida (Set Lightweight to Resolved). 

o Uma pena na árvore de projeto do FeatureManager também indica vistas de 
peso leve. 

• Desenhos desanexados não podem ser peso-leve. 
• Com desenhos peso-leve você pode: 

o Criar todos os tipos de vistas de desenho 
o Anexar anotações aos modelos nas vistas 
o Dimensionar modelos nas vistas 
o Especificar propriedades da aresta 
o Selecionar arestas e vértices 
o Definir desenhos de submontagens como peso leve ou resolvido 

• Se imprimir um desenho peso leve quando estiver fora da sincronização com o 
modelo, o desenho será impresso com uma marca d’água: 

o Desenho peso leve do SolidWorks – Impressão desatualizada 
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Outras dicas de desenho: 
• Sempre use vistas de Alta qualidade 
• Use vistas sombreadas para desenhos de layout 

o Modifique configurações do sistema para refletir: Ferramentas (Tools) > 
Opções (Options) > Estilo de exibição (Display Style) > Sombreado (Shaded) 

 

 
Use vistas sombreadas no layout de um desenho (mais rápido) 

 
 

• Use configurações para minimizar detalhes desnecessários nos desenhos: 
o É possível alternar as configurações posteriormente 

• É melhor usar menos vistas por folha 
o Em vez disso, use várias folhas ou desenhos 

• Atualize somente vistas individuais 
• Se você usa configurações e ainda pode preservar a numeração de BOM 

o Se você usa configurações e supressão, é possível manter a numeração 
 

 
Ao utilizar configurações você pode suprimir ou manter a numeração de BOM 
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• IMPORTANTE: Tenha cuidado com o uso de configurações, vistas de seção, 
vistas de detalhes e vistas de posição alternada 

o Quanto mais configurações um desenho fizer referências, mais tempo será 
necessário para atualizar o desenho. Cuidado com o número de 
configurações a que um desenho em particular faz referência 

o O SolidWorks precisa tocar, reconstruir e armazenar na memória cada 
configuração para manter o desenho atualizado 

o Configurações, seções, detalhes e vistas de posição alternativa são 
essencialmente “modelos novos” no ambiente de desenho 

• Dica: Tenha cuidado com o número total de folhas 
o considere dividir várias folhas em vários arquivos 

• Verifique se há interferências antes de ativar vistas de desenho HLR 
o a ambigüidade em relação ao que é exibido ou não exibido afeta o tempo de 

criação da vista de desenho 
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Peças: 
 
Técnicas de modelagem 

• Defina totalmente seus esboços, eles serão resolvidos com mais rapidez 
• Solucione erros de reconstrução 
• Não modele roscas, a menos que seja absolutamente necessário! 

o Use representações de rosca se for necessário para efeito visual 
o Modele somente roscas funcionais (ou seja, parafuso de Arquimedes, 

alimentação de parafuso etc.) se for absolutamente necessário. Mesmo 
assim, suprima-as no nível de montagem superior, se possível 

• Evite usar texto para recursos; em vez disso, use um esboço ou desenhe letras 
simplificadas 

• Minimize os detalhes desnecessários – use entidades de esboço 
 

 
Não crie recursos para detalhes desnecessários 

 
• Use templates diferentes para armazenar Configurações do documento para 

componentes específicos 
o Acelere a verificação de interferência usando templates para armazenar o 

“CompFix” (IsFastener), que designa o componente como um componente 
de fixação para verificações de interferência. Isso ignorará a interferência 
criada pelo fato de a rosca ser um cilindro 

 

 
Definição da propriedade “CompFix” 
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• Filetes 

o Se possível, adicione filetes por último e suprima-os quando não forem mais 
necessários 

o Combine filetes de mesmo tamanho em um recurso 
• Padrões 

o Evite exibir padrões grandes ou complexos no nível de montagem superior 
(ou seja, padrão de preenchimento) 

o Experimente a opção “Padrão de geometria” (Geometry pattern) ao criar um 
padrão – é mais rápido em regerações 

• Molas 
o Não modele detalhes de mola e evite modelar hélices. Use um cilindro para 

representar a mola 
• Geometria importada 

o Ao utilizar o FeatureWorks, crie somente recursos em peças se for 
necessário. Deixe como geometria importada se os recursos do SolidWorks 
não forem necessários 

o Quando possível, verifique se toda geometria importada está totalmente 
costurada para criar um sólido 

o Modele montagens apropriadas como peças em vez de como montagens 
(ou seja, rolamentos). Você pode usar “Salvar como peça” (SaveAs Part) 

 
 

SolidWorks – Confidencial 



Gerenciamento de dados: 
 
Por que é importante usar o PDMWorks Workgroup ou Enterprise para trabalhar com 
grandes montagens? 

• Utilizado com mais freqüência em um ambiente multiusuário 
• Policiamento de dados 

o Um sistema PDM gerencia quem tem o controle de arquivos para modificação. 
o Evita a sobregravação e a perda de dados 

• Controle de revisão 
o Controla o nível de revisão de arquivos 
o Conhece o nível de revisão correto de todos os componentes de uma revisão 

de montagem ou desenho em particular 
• Controla o acesso ao projeto 
• O PDM sabe quando uma peça foi alterada 

o Mesmo alterações no contexto que você talvez não tenha o costume de 
selecionar manualmente 

o Um sistema PDM torna uma técnica de projeto de cima para baixo muito 
mais fácil de ser usada em um ambiente de equipe 

o Alterações acidentais são evidenciadas por avisos (ou seja, tentando alterar 
arquivos somente leitura) 

• Coloca arquivos em sua unidade local para que você possa abri-los localmente. 
É mais rápido do que executar pela rede se o SolidWorks precisar abrir 
configurações ou resolver componentes de peso leve 

 
PDMWorks Workgroup vs. PDMWorks Enterprise 

• PDMWorks Workgroup 
o Geralmente até 10 usuários 
o Projetos que requerem compartilhamento de componentes 
o Controle de revisão 

• PDMWorks Enterprise 
o Geralmente mais de 10 usuários 
o Tudo que o PDMWork Workgroup faz e mais: 

 Apto a vários locais 
 Apto a fluxo de trabalho 

 
Outras ferramentas para localizar e gerenciar dados do projeto 

• Pesquisa do SolidWorks 
o Maneira mais fácil de localizar e abrir arquivos 
o Uma única ferramenta para pesquisar em todos os pontos por arquivos, 

inclusive no PDM 
o Pode pesquisar em metadados (propriedades) 

• Preparar e enviar 
o Arquivo (File) > Preparar e enviar (Pack and Go) 
o Uma ferramenta excelente para organizar seus arquivos e enviar a clientes e 

fornecedores 
o Cria um arquivo .zip ou salva em uma nova pasta 
o Salva automaticamente todas as peças, montagens referidas, etc. 
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Ferramentas para verificação de dados do projeto 
• Utilitários – Comparar geometria 

o Permite comparar alterações na geometria e nos recursos da peça com 
facilidade 

o Exibe as diferenças graficamente 
• SolidWorks Design Checker 

o Verifica se os padrões da empresa foram atendidos 
o Aprender a partir de um desenho existente 
o Correção automática de verificações 
o Verificador ortográfico 
o Verifica se há tamanhos de furo fora do padrão 
o Automação com o SolidWorks Task Scheduler 
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Hardware: 
 
Onde estão localizados os requisitos de hardware para executar o SolidWorks? 

• Os requisitos de hardware estão listados no Portal do cliente do SolidWorks, 
em Requisitos do sistema 

RAM 
• O requisito mais importante para lidar com grandes montagens é ter uma memória 

RAM suficiente 
• Se você não tiver o suficiente, os dados de grandes montagens serão transferidos 

(deslocando RAM para o disco) 
Máquina de 32 bits ou 64 bits? 

• As máquinas com 32 bits possuem um limite de RAM de 2 GB – uma vez excedido, 
você estará deslocando para o disco, o que é muito mais lento 

• A razão principal para escolher máquinas de 64 bits (e SO de 64 bits) é para ter 
mais memória 

• As máquinas de 64 bits serão mais rápidas em montagens que excedam o limite de 
2 GB de sistemas de 32 bits 

• Para todos os grandes modelos que excedam o limite de 2GB da arquitetura de 
32 bits, recomendamos um processador X64 com 6 GB ou mais 

Memória virtual 
• Recomendamos que a memória virtual tenha 2X a capacidade da RAM 

Vários núcleos e várias CPUs 
• Mais rápido, a menos é claro que você precise da memória 
• Alguns aspectos do SolidWorks são de tecnologia de multiencadeamento. 

O processador dual core (núcleo duplo) beneficia-se desse recurso 
o PhotoWorks 
o Cosmos 
o Conversão de arquivo 
o Remoção de linhas ocultas 

Placa de vídeo 
• Efetua giro e rotação, zoom e panorâmica 
• Recomendado: um driver e uma placa gráfica de estação de trabalho OpenGL certificada 
• Consulte o Portal do cliente do SolidWorks em Hardware e Gráficos sobre placas 

certificadas 
• Dica: Se as suas montagens estão sendo executadas próximo ao limite máximo de 

RAM disponível, uma placa gráfica de nível inferior seria melhor, pois uma placa 
de 512Mb mapeará para 512Mb de RAM 

Desfragmentação 
• Execute a desfragmentação de disco regularmente 
• Não desfragmente, pois o SolidWorks usa alguns dados compartilhados por esses 

utilitários 
Service Packs – mantenha-se atualizado com os service packs 

• Muitos erros podem ser corrigidos em diferentes versões de service packs tanto para 
o SO quanto para o SolidWorks 

Rede 
o Devem ser todas de 100Mb ou 1Gb e separadas de outro tráfego de rede por um gateway 

SolidWorks – Confidencial 



Ambiente: 
 
Local do arquivo: MUITO IMPORTANTE 

• O fator número 1 de desempenho é onde as peças estão localizadas 
• Os arquivos devem ser locais para um melhor desempenho 
• Se for preciso obter peças da rede (geralmente um ambiente multiusuário, onde os 

dados são compartilhados), então use o PDMWorks 
o O PDMWorks criará uma cópia local do arquivo que pode ser alterada; 

a vantagem do PDMWorks é que somente as peças alteradas são copiadas 
o Se os arquivos são locais, o SolidWorks precisa apenas ler as definições para 

a configuração atual da montagem 
o Se as peças estão em um local diferente da unidade local, o arquivo inteiro 

será copiado para um local temporário (sessão atual somente) antes que as 
configurações necessárias sejam lidas 

• Rotina de pesquisa de documentos referidos 
o Nota: Quanto mais caminhos de pesquisa o software tiver de atravessar 

para localizar documentos na rede, mais lento será o desempenho geral.  
Isso é mais evidente na abertura de arquivos, ao salvar arquivos, alterar 
configurações, definir Peso leve como resolvido – qualquer operação 
que precise acessar informações adicionais no disco. 

o Quando o SolidWorks abre um documento referido, ele executa uma pesquisa 
para localizar o documento. Essa pesquisa pode ocorrer, por exemplo, quando 
você abre um desenho e a montagem referida não pode ser localizada, ou 
quando você resolve um componente de peso leve em uma montagem 

o Quando o documento referido é encontrado, o software atualiza o seu 
caminho no documento pai. Quando o documento pai for salvo, o caminho 
atualizado também será salvo. 

o A coluna Regras a seguir descreve a rotina de pesquisa utilizada pelo 
software para localizar um documento referido que está faltando. 

o A coluna Exemplos mostra os caminhos que o software verifica usando o 
seguinte cenário: 

 A montagem foi salva pela última vez como C:\zz\a1.sldasm. Você 
move a montagem para D:\ss\tt\a1.sldasm. 

 A primeira peça na montagem foi salva pela última vez como 
C:\qq\p1.sldprt. Você não move esta peça. 

 A segunda peça na montagem foi salva pela última vez como 
C:\zz\yy\xx\p2.sldprt. Essa peça está faltando, seja porque foi 
excluída ou renomeada, ou porque houve algum erro no 
gerenciamento dos arquivos. 

 Existem dois caminhos na lista de Pastas da caixa de diálogo Opções 
de locais de arquivos: D:\aa\bb\ and E:\cc\dd\ 

 Você clica em Arquivo, Abrir para abrir a1.sldasm nesse novo local. 
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Regras Exemplos 
1. Usa qualquer documento aberto com o mesmo 

nome. 
Se p2.sldprt estiver em outro 
documento aberto, o 
SolidWorks usa esta versão 
de p2.sldprt. 

2. Pesquisa o primeiro caminho que você especificar 
na lista de Pastas na caixa de diálogo Opções de 
locais de arquivo. 

NOTA: Você deve marcar a caixa de seleção 
Pesquisar referências externas em locais de 
arquivos na caixa de diálogo Opções de 
referências externas, caso contrário, o SolidWorks 
ignora os caminhos que você especificar. 

D:\aa\bb\p2.sldprt 

3. Pesquisa o caminho na Etapa 2 e a última pasta no 
caminho onde o documento referido foi salvo pela 
última vez. 

D:\aa\bb\xx\p2.sldprt 

4. Pesquisa o caminho na Etapa 2 e as últimas duas 
pastas no caminho onde o documento referido foi 
salvo pela última vez. 

D:\aa\bb\yy\xx\p2.sldprt 

 
 

5. Repita a Etapa 4 até que o caminho original 
completo tenha sido adicionado ao caminho da 
Etapa 2. 

NOTA: Este conceito de adição de uma pasta por 
vez do caminho completo será chamado “pesquisa 
recursiva” nas próximas etapas. 

D:\aa\bb\zz\yy\xx\p2.sldprt 

6. Executa uma pesquisa recursiva no primeiro 
caminho da lista Pastas, em seguida executa uma 
pesquisa recursiva no caminho onde o documento 
referido foi salvo pela última vez. 

D:\aa\xx\p2.sldprt 

D:\aa\yy\xx\p2.sldprt 

D:\aa\zz\yy\xx\p2.sldprt 

D:\xx\p2.sldprt 

D:\yy\xx\p2.sldprt 

D:\zz\yy\xx\p2.sldprt 
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Regras Exemplos 
7. Repete as Etapas 2 a 6 para outras pastas na 

lista Pastas. 
E:\cc\dd\p2.sldprt 

E:\cc\dd\xx\p2.sldprt 

E:\cc\dd\yy\xx\p2.sldprt 

E:\cc\dd\zz\yy\xx\p2.sldprt 

E:\cc\xx\p2.sldprt 

E:\cc\yy\xx\p2.sldprt 

E:\cc\zz\yy\xx\p2.sldprt 

E:\xx\p2.sldprt 

E:\yy\xx\p2.sldprt 

E:\zz\yy\xx\p2.sldprt 
8. Pesquisa o caminho do documento ativo e depois 

executa uma pesquisa recursiva no caminho onde 
o documento referido foi salvo pela última vez. 

D:\ss\tt\p2.sldprt 

D:\ss\tt\xx\p2.sldprt 

D:\ss\tt\yy\xx\p2.sldprt 

D:\ss\tt\zz\yy\xx\p2.sldprt 

D:\ss\xx\p2.sldprt 

D:\ss\yy\xx\p2.sldprt 

D:\ss\zz\yy\xx\p2.sldprt 

D:\xx\p2.sldprt 

D:\yy\xx\p2.sldprt 

D:\zz\yy\xx\p2.sldprt 
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Regras Exemplos 
9. Pesquisa o caminho onde você abriu um 

documento pela última vez e depois executa uma 
pesquisa recursiva no caminho onde o documento 
referido foi salvo pela última vez. 

NOTA: Na maioria dos casos, o caminho do 
documento ativo e o caminho onde você abriu 
um documento pela última vez são os mesmos. 

Os dois caminhos são diferentes se você clicar em 
Arquivo, Abrir para abrir um documento, depois 
arrastar e soltar uma montagem do Windows 
Explorer neste documento. O caminho do 
documento ativo é o caminho do Windows Explorer, 
e o caminho de onde você abriu um documento pela 
última vez é aquele em Arquivo, Abrir. 

O mesmo que a Etapa 8. 

10. Pesquisa o caminho onde o software localizou um 
documento referido pela última vez. 

C:\qq\p2.sldprt 

Este é o local do p1.sldprt. 
11. Pesquisa o caminho completo onde o documento 

foi salvo pela última vez sem a determinação de 
uma unidade.  

Isso é útil se você salvar uma 
peça em um caminho UNC, 
como \\machine\folder\p2.sldprt. 

12. Pesquisa o caminho completo onde o documento 
foi salvo pela última vez com a determinação de 
sua unidade original. 

C:\zz\yy\xx\p2.sldprt 

13. Permite procurar o documento manualmente. n/d 

 
Arquivo de diário (Journal File) 

• Verifique se o arquivo de diário é local, já que você não vai querer gravar um 
arquivo de diário na rede 

• Você pode definir o local do arquivo de diário em: Ferramentas (Tools) > Opções 
(Options) > Locais de arquivo (File Locations) 

Backup/Recuperar 
• Para obter um desempenho mais rápido, desative esta opção 
• Se realmente deseja fazer backups, verifique se o local do arquivo de recuperação é 

local e que a freqüência é apropriada 
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Próximas etapas: 
 
Não há substitutos para um bom treinamento. Consulte as suas revendas para saber como 
participar de cursos, que incluem Montagens avançadas, Projetos avançados e PDMWorks. 
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